Announcement

Collapse
No announcement yet.

with no warning it just died

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Eagle-Mark
    replied
    Basic diagnostics would point to the battery connections and grounds like SandRacer said (nice to see you back) but this is a Scout so the first thing I would look at would be the bulkhead connections!
    When I did my body lift the truck would not start or show any signs of life. Battery checked out like you said. I even checked voltage at the starter, it was confusing. But from moving the body around the one just came loose. Take a look at them there are two and they are notorious for gremlin electrical problems. If you pull one off and look inside leave the grease in them.
    Hope that helps!

    Leave a comment:


  • Guest's Avatar
    Guest replied
    The next place I would look is for a dirty or loose ground either at the battery or where the cable attaches. That is, if you haven't checked it already.

    What kind of shape are your battery cables in?

    Leave a comment:


  • Guest's Avatar
    Guest started a topic with no warning it just died

    with no warning it just died

    Ive never seen anything like this happen before...I had been driving my 76 scoutII all day sunday with no problems. out of the blue it just died...completely...nothing works, not even the headlights. obviously its an electrical problem but i was just wondering if this has happend to anyone. i tried checking the battery(13.7 volts..thats plenty) the alternator connection and starter connection were all fine as well. i think i may just have to get in there and check every single wire to fire the problem. Any info would be greatly appreciated. gotta get my rig back to life!
Working...
X